Our Browser Policy

The development of iSAMS with multi-browser compatibility has required that we create a high level Browser Policy that outlines the browsers we will officially support.

It has been agreed that the following browsers will be supported:

  • Chrome
  • Edge
  • Internet Explorer (v11 only)
  • Firefox
  • Safari

Please note that we will only support the current and previous major releases of these browsers. Each time a new version is released, we will begin to support that version and stop supporting the third most recent version.

That is not to say iSAMS would cease to function in previously supported browsers, they would just no longer be covered by our support and testing.

Note that the above browsers are supported at a minimum screen resolution of 1280 x 1024.

Compatibility View

Please be aware that Internet Explorer has a Compatibility View feature and further configuration will need to be taken into account if you run iSAMS within your internal network. When “Compatibility View” is enabled, it uses a non-standards compliant method of rendering which is most similar to Internet Explorer 7.

Unfortunately, there is no way for iSAMS to override this setting within the software and we recommended that you either turn off Compatibility View or remove iSAMS from your list of sites that have Compatibility View enabled. To disable this setting, visit the “Compatibility View Settings” dialog and uncheck “Display Intranet Sites in Compatibility View”. Alternatively, you can set this via Group Policy.

Please note, this only affects sites that are hosted within your network; external sites will not be affected. If you do have sites that require Compatibility View, use the whitelist feature within Internet Explorer or set up via Group Policy.

Microsoft has announced that “Compatibility View” is going to be deprecated in the next version of Internet Explorer, codenamed “Spartan”.

What about other vendors?

Future development of iSAMS will be heavily based around common web standards such as HTML5 and CSS3. Whilst we may not officially support your browser of choice, assuming it conforms to these web standards, there should be no reason why you cannot use it with iSAMS.

Our list of officially supported browsers simply outlines our commitment to providing bug fixes and testing for these vendors.

Why have we made these decisions?

The internet and web technologies are constantly changing and progressing at a fast pace. In order to keep up with these advances and to ensure that we can consistently deliver cutting edge technology to our clients we need to ensure that they are running the most modern web browsers.

Many of the main browser vendors have moved to an incremental update model, where browsers are updated at regular intervals with the latest improvements and fixes. In addition, modern browsers are slowly converging on common web standards, which provides us as developers far less cross-browser concerns, greater development options and ultimately increased productivity.

There are many reasons why it is a good idea to ensure your users are using the latest versions of modern browsers. This includes concerns about security right through to maximising performance in the browser.